
Lab 1.3 Using the WWW
Lab Overview
Objectives
After completing this lab, you will be able to:

 Use the Internet Explorer to browse local files and WWW resources.
 Use the Internet Explorer to download files.
 Search for resources on the Internet using WWW search engines.
 Create and manage Windows Internet shortcuts.

Scenario
As a prerequisite for the rest of this course, which concentrates almost exclusively on the World Wide 
Web, you must learn how to access, navigate, and efficiently use the Web. Your main client interface to 
the Web will be the Microsoft Internet Explorer.

Lab Setup
This exercise assumes that you have Microsoft Internet Explorer installed and have Internet access. The
first exercise also assumes that you have installed either Microsoft Office 95 or the free Microsoft Office 
viewers. These viewers can be found in the Library section of this CD-ROM, under Microsoft Tools.

Estimated time to complete this lab: 45 minutes

Exercises
The following exercises provide practice working with the concepts and techniques covered in this 
chapter. 

Exercise 1: Using the World Wide Web
This exercise has two parts. In the first part, you will use Internet Explorer 3.0 to open and view local files
on the Mastering Internet Development CD-ROM. In the second part of the exercise, you will use 
Internet Explorer to browse the Microsoft web site http://www.microsoft.com. You will navigate down the 
Internet development branch of the document, and you will be given the option of downloading the latest 
version of the Microsoft Internet Information Server (IIS).

Exercise 2: Using URLs and Internet Shortcuts
In this exercise, you will explore how URLs are encapsulated as Internet shortcuts by the Microsoft 
Windows operating system, and how these shortcuts can be used in Windows and Windows-based 
applications.

Exercise 1: Using the World Wide Web
This exercise has two parts. In the first part, you will use Internet Explorer 3.0 to open and view local files
on the Mastering Internet Development CD-ROM. In the second part of this exercise, you will use 
Internet Explorer to browse the Microsoft web site http://www.microsoft.com. You will navigate down 
the Internet development branch of the document, and you will be given the option of downloading the 
latest version of the Microsoft Internet Information Server (IIS).

 Use Internet Explorer 3.0 to view local files
One of the primary functions of Internet Explorer is to view files. To extend its usefulness to the Internet, 
it also happens to be a client for many of the standard higher-level protocols like NNTP, FTP, gopher, 
and HTTP. However, you can demonstrate many of its file-viewing capabilities on local files.
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1. Start Internet Explorer. Place the Mastering Internet Development CD-ROM in an accessible CD-ROM
drive. It should display your start page. From the File menu, choose Open. In the Open dialog box, 
choose the Browse button. In the Open File common dialog box, navigate to the CD-ROM drive, then 
to the directory \Labs\Lab01.3\. This directory has several local sample files for you to view with 
Internet Explorer.

2. Open the first file from the list below. For each of the following files, you can edit the string in the 
Address/Open edit box found just underneath the toolbar on Internet Explorer.

Text.txt - a plain text file
Hypertxt.htm - an hypertext markup (HTML) file
Bitmap. gif - a bitmap file (CompuServe's Graphic Image Format)
Picture.jpg -a bitmap file (Joint Photographer's graphic format)
Movie.avi - a multi-media file (Windows Audio-Video Interleaved format)
Sound.wav - a sound file (Windows format)
Virt3D.xof - a virtual reality markup language (VRML) file. (To view this file format, you will need a 
newer version of IE 3.0 than is included on the Mastering Internet Development CD-ROM.)

All of these files type are native to Internet Explorer because they are displayed directly within the 
context of the client area.

3. Repeat the procedure in Step 2 with each of the Microsoft Office files below.
WinWord.doc - a Word for Windows document
Sprdsht.xls - a Microsoft Excel spreadsheet

Each of these files are displayed in the client area of Internet Explorer, but their display is handled by 
the associated DocObject server. Notice that when you load each of these files, the menu structure of
Internet Explorer changes partly to reflect that of the server application.

4. Repeat the procedure in Step 2 with each of the files below.
Write.wri - a Windows Write editor file
Sol.hlp - a Windows Help file

These files have a known associated helper application type. To see a list of MIME file associations, 
from the View menu, choose Options. In the Options property sheet, choose the File Types property 
page. These MIME types associate a file content type with a filename extension and a helper 
application.

5. Repeat the procedure in Step 2 with each of the files below. Because these files have no associated 
helper application, you must specify an application to open each of them.

Shape1.shp - the MFC Shapes program serialization file. Open With Shapes.exe.
Shapes.exe - click Open to execute this program.

Note that the first time you run Shapes, it registers the file extension .SHP in the Windows registration
database.

 Browse the Microsoft WWW site
1. In the Address text box, type http://www.microsoft.com and press ENTER. The Microsoft home 

page should appear. Briefly browse the information on this page.
2. Slowly move the mouse cursor over the graphics and links on this page. (Text links are denoted by 

underlined words.) Note that the cursor changes to a hand shape and the status bar indicates where 
the link is connected to. 

3. Navigate to the What's New page by clicking on the corresponding linked graphic at the top of the 
page. Briefly scan the contents of the page. Click on one of the topics (for example, Microsoft Press) 
to jump to that page. Continue browsing down into the site by clicking on more specific links.

4. Return to the Microsoft home page by one of the following methods:
 Click the back arrow on the toolbar to traverse the navigation tree back to the home page.
 From the Address Window list box, choose the URL for the Microsoft Web site. 
 Click the down arrow on the far right of the Address text window, and choose 

http://www.microsoft.com from the drop-down choices.
 If you are on a page that contains a Microsoft navigation graphic, click on it to take you back.
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 Save information about the site
Internet Explorer has a number of methods you can use to retain information about a site. In addition to 
the ones discussed in this step, the next lab will also show you how to use URLs and Internet shortcuts 
in the Windows operating system and in Windows-based applications. 

1. If you have a access to a printer from your system, print the Microsoft home page. To print a single 
page, from the File menu, choose Print. The Print dialog box is displayed. Internet Explorer cannot 
print an entire site in one operation. 

2. To view the HTML source code for the page, do one of the following:
 From the View menu, choose the Source command.
  Right-click on a blank area in the page. From the View menu, choose View Source. 

The HTML source code for the page is displayed in the default Windows text editor (most likely 
Notepad or WordPad). Note that embedded objects, like graphic images, are only referenced by 
filename. Since the source code is now in an editor, you can save this to a file, preferably with 
an .HTM or .HTML extension.

3. To access an embedded graphic object, right-click on the object. From the context menu, choose 
Save Picture As. In the Save As common dialog, save the graphic to a local drive. Now, locate this file
with the Windows Explorer, then double-click on the file to activate it. The .GIF file will be displayed in 
the Internet Explorer or with another graphics-viewing application. Return to the Microsoft home page.

4. To perform text-based operations, like Cut and Paste, Internet Explorer has a standard Edit menu. 
From the Edit menu, choose Select All (CTRL+A). Then, from the same menu, choose Copy (CTRL+C).
Start Microsoft Word or WordPad and Paste (CTRL+V) the information into a new document. Note that
the formatting is lost, and embedded graphics are denoted by only a <picture> placeholder. The Edit 
menu also has a Find(On This Page) command for locating simple text strings within a page.

5. To save the current page as one of your favorites, use one of the following methods to display the 
Add To Favorites dialog box:
 Right-click on an empty area of a page and choose Add To Favorites from the context menu.
 From the Favorites menu, choose the Add To Favorites command.

The Add To Favorites dialog allows you to save the associated Internet shortcut in your Favorites 
folder. You can even manage the shortcuts by creating subfolders.
Using one of these methods, save the Microsoft home page as a favorite. Then, pull down the 
Favorites menu and select this new entry, Microsoft Corporation, to go to the address 
www.microsoft.com.

 Download software from the Microsoft site
Like FTP, one of the conveniences of the Web is the ability to download files to your local hard disk. 
Many computer companies, including Microsoft, make available many updates and utilities for the Web 
user.

1. Open the Microsoft home page, http://www.microsoft.com, in Internet Explorer.
2. Scroll down the page until you see an offer to download the Internet Explorer. Click on the associated 

link to go to the Microsoft Internet Explorer page. This page allows you to download versions of 
Internet Explorer for Windows 95, Windows NT, Windows 3.1, and the Macintosh. Note that these 
versions of the browser may be newer than the one included with this course.

3. Download the version appropriate to your computer. You will receive a Confirm File Open dialog box, 
which allows you to execute (Open) or save the file (Save As). Save this file to a local directory. Note 
the quoted size of the file on the HTML page.

4. Use the Windows Explorer to confirm the presence of the local copy of this downloaded file. Check 
the size of the copy versus the quoted size. (This is always a wise procedure to follow when 
downloading files.)

5. If you want to update your version of Internet Explorer, click on the appropriate download link, but 
choose Open from the Confirm File Open dialog box. You should then restart Windows to ensure a 
successful upgrade.
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 Search the contents of the WWW 
Because the World Wide Web has no directory services or overall organization, four general methods 
are used to search for information on the Web: subject trees, WAIS database gateways, Internet indexes
(or catalogs), and search engines.

1. In Internet Explorer, from the Go menu, choose the Search The Web command. You will be taken to 
the Internet Searches page of The Microsoft Network (MSN) home page. (Note that this is not the 
MSN online service, but only their WWW presence.) This page allows you to search the Internet using
the following six services: Excite, Infoseek, Lycos, Magellan, Yahoo, and a Microsoft-only search 
service.

2. In the Excite search box, type the string  Windows AND (95 OR NT) AND Internet and choose 
Search (or press ENTER). The results of the search should be displayed in a new page. By default, the
matches are sorted by confidence level, with the higher scores shown first.

3. Repeat the search using the Microsoft search service. Since this search only covers 
www.microsoft.com, the number of matches is much less.

 If time permits, browse the Internet Resource Center area of the Microsoft site
1. Return to the Microsoft home page. Click on the Internet Resource Center link to go to that page.
2. Using this page as your base, browse some of the information and software available from this section

of the Microsoft site.

 If time permits, investigate some additional sites
The following Web sites represent just a tiny fraction of the varied, entertaining, and useful information 
that can be found on the Internet. 

1. www.altavista.digital.com - Digital Equipment Corporation's very powerful search service.
2. www.occ.com - The Internet's Online Career Center, search for employment or post positions over 

the Internet.
3. www.whitehouse.gov - Web site of the Executive branch of the U.S. federal government.
4. www.sciencedaily.com - An electronic magazine devoted to science news and reporting.
5. www.shareware.com - Locate and download shareware and freeware on the Internet.

Exercise 2: Using URLs and Internet Shortcuts
In this exercise, you will explore how URLs are represented as Internet shortcuts by the Windows 
operating system, and how these shortcuts can be used in Windows and Windows-based applications.

 Managing favorite shortcuts in Microsoft Internet Explorer.
1. Go to the Microsoft home page at http://www.microsoft.com
2. Right-click on a link on the page. From the shortcut menu, choose the Add To Favorites command. In 

the Add To Favorites dialog box, choose Add to add this link to your Favorites folder. Repeat this 
procedure with two or three more links.

3. From the Favorites menu, choose Open Favorites Folder (or click the Favorites toolbar button). The 
C:\Windows\Favorites folder is displayed within Internet Explorer. Change the folder view to Details.
Note that each Internet shortcut is only 1K in size.

4. Right-click on one of the shortcuts, and choose Properties from the shortcut menu. This displays the 
Properties dialog box for that shortcut. Examine the General and Internet shortcut property pages. 
Click Cancel.
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5. Start Notepad, then open one of these Internet shortcut files. (The path to the file will be in the 
address box of Internet Explorer.) Its contents should be small and look something like this:

[internetShortcut]
URL=http://www.microsoft.com/infouser/suiteover.html

Note that if you examine a normal Windows shortcut (for example to a folder), it will contain binary 
information. Close Notepad.

6. Reorganize the new links into a new folder. Create a new folder named "Microsoft Resources" inside 
of Favorites. Drag the new shortcuts into this folder. In Internet Explorer, click the Favorites menu, 
and then click the Microsoft Resources submenu to reveal the new shortcuts. Pick a shortcut to go to 
that page. 

7. Produce Internet shortcuts on the Windows desktop. Return to the Microsoft home page. Drag and 
drop a text link from this page to the desktop. An Internet shortcut to that URL will be created on the 
desktop.
Place the mouse cursor on the graphic in the far-right side of the status bar. Drag and drop this icon 
to the desktop. You have now produced an Internet shortcut to the currently displayed page. 

Note  At the time of this writing, only the Windows desktop, Windows folders, and a few applications 
like Microsoft Exchange recognize Internet shortcuts. If, for example, you try to drop a shortcut into 
WordPad, you will receive the text representation of the corresponding URL.

8. Test one of the Internet shortcuts you placed on the desktop. 
Close Internet Explorer. Double-click on one of the shortcuts you produced in the last step. This 
should launch Internet Explorer with the corresponding URL as the target.

 Using Internet shortcuts in mail
As mentioned in the previous section, the Microsoft Exchange client is aware of Internet shortcuts. 
Exchange also automatically links text URLs in messages to their associated Internet client application, 
such as the Internet Explorer.

1. Open Internet Explorer and the Microsoft Exchange client (Inbox icon) applications. 
2. Create a new mail message. Address it to yourself. 
3. Tile Internet Explorer and the new message on the Windows desktop. From Internet Explorer, drag a 

link to the new message body.
4. Copy and paste the URL from the address box of Internet Explorer to the mail message.
5. Send the message. When you receive the message in your Inbox, open it.
6. Click on the Internet shortcut icon. Repeat this process with the plain text URL, which should be 

underlined and colored now. Note that both launch Internet Explorer and take you to the associated 
Internet resource.
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